Updating time zones fatal error

posted by | Leave a comment

If you are updating plugins manually, it is a good moment now to check in the Moodle Plugins directory whether there is a 2.9 version available for any plugins (including themes) that you have previously installed on your site. In the next step, you will copy it to the appropriate location in your Moodle code (see Installing plugins).The upgrade of the plugin will then happen as part of the Moodle upgrade process.In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier.We selected 'UTC' for 'GMT/0.0/no DST' instead' in /somepath/symphony/lib/core/class.datetimeobj.php:265, referer: [some referrer] [some date] [warn] [client [rogue IP mod_fcgid: stderr: Stack trace:, referer: [some referrer] [some date] [warn] [client [rogue IP]] mod_fcgid: stderr: #0 /somepath/symphony/lib/core/class.datetimeobj.php(265): Date Time-__construct(), referer: [some referrer] [some date] [warn] [client [rogue IP]] mod_fcgid: stderr: #1 /somepath/symphony/lib/core/class.datetimeobj.php(222): Date Time Obj::parse('now'), referer: [some referrer] [some date] [warn] [client [rogue IP]] mod_fcgid: stderr: #2 /somepath/symphony/lib/core/class.datetimeobj.php(199): Date Time Obj::format('now', 'c', false, NULL), [some referrer] [some date] [warn] [client [rogue IP]] mod_fcgid: stderr: #3 /somepath/symphony/lib/core/php(342): Date Time Obj::get('c'), referer: [some referrer] [some date] [warn] [client [rogue IP]] mod_fcgid: stderr: #4 /somepath[truncated] in /somepath/symphony/lib/core/class.on line 265, referer: [some referrer] I checked and it's still setting the correct timezone. Please note that if you use My SQL you must upgrade the engine to Inno DB since it has become a requirement in Moodle 2.9. Note: You can only upgrade to Moodle 2.9 from Moodle 2.2 or later.If upgrading from earlier versions, you must upgrade to 2.2 as a first step.I could see no changes to the files that the error log was complaining about.This all seems to coincide with an apparent bot that was searching for files like You get the idea.

||

If you are updating plugins manually, it is a good moment now to check in the Moodle Plugins directory whether there is a 2.9 version available for any plugins (including themes) that you have previously installed on your site. In the next step, you will copy it to the appropriate location in your Moodle code (see Installing plugins).

The upgrade of the plugin will then happen as part of the Moodle upgrade process.

]]

Before you begin upgrading your site, you should put it into maintenance mode to stop any non-admin users from logging in.Anyone with issue please check your Joomla version under Site/System Information and make sure it's the version below or newer.I think you might have installed the 2.5 version instead of the 3.0 version try uninstalling your current installation (Note: Just uninstall the component and it will take care of the other parts of the extension).The My SQL installation procedure creates the time zone tables, but does not load them.You must do so manually using the following instructions.

Leave a Reply

love and dating information